We are observing good MO and SMS delivery receipt performance from our supplier. This incident has been resolved.
Posted Sep 25, 2025 - 12:25 BST
Investigating
The speed of inbound SMS and delivery receipts into our network is currently degraded. We are working with our supplier to troubleshoot further. Updates to follow.
Posted Sep 25, 2025 - 10:45 BST
This incident affected: UK SMS (UK Inbound Messages, UK Delivery Receipting), International SMS (International Inbound Messages), Textlocal API (API Reporting), and Textlocal Messenger (SMS Reporting).