Speed of Inbound SMS & Delivery Receipts Degraded..

Incident Report for Textlocal

Resolved

We are observing good MO and SMS delivery receipt performance from our supplier. This incident has been resolved.
We are currently processing a small queued of MO SMS and Delivery Receipts and expect this to complete shortly.
Posted Sep 22, 2025 - 13:15 BST

Monitoring

Our supplier has made an adjustment and we are now seeing MO traffic and delivery receipts hitting our network in a timely fashion. We are monitoring the results.
Posted Sep 22, 2025 - 12:39 BST

Investigating

The speed of inbound SMS and delivery receipts into our network is currently degraded. We are working with our supplier to troubleshoot further. Updates to follow.
Posted Sep 22, 2025 - 09:28 BST
This incident affected: UK SMS (UK Inbound Messages, UK Delivery Receipting), Textlocal API (API Reporting, Delivery Receipting to Remote), and Textlocal Messenger (SMS Reporting).