Issues Purchasing and Renewing
Incident Report for Textlocal
Resolved
Our payment provider has resolved the issues preventing purchases. We apologise for the inconvenience caused,
Posted Mar 21, 2022 - 15:53 GMT
Monitoring
Our payment provider has informed us that some purchase attempts may fail to complete as they are experiencing a technical issue. They are currently investigating and will aim to resolve the issue as soon as possible. We apologise for any inconvenience caused.
Posted Mar 21, 2022 - 15:23 GMT
This incident affected: Textlocal Messenger (Payment Pages).